summaryrefslogtreecommitdiffstats
path: root/src/common/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/common/CMakeLists.txt')
-rw-r--r--src/common/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
index 13ed68b3f..efc4a9fe9 100644
--- a/src/common/CMakeLists.txt
+++ b/src/common/CMakeLists.txt
@@ -155,6 +155,14 @@ if (WIN32)
target_link_libraries(common PRIVATE ntdll)
endif()
+if(ANDROID)
+ target_sources(common
+ PRIVATE
+ fs/fs_android.cpp
+ fs/fs_android.h
+ )
+endif()
+
if(ARCHITECTURE_x86_64)
target_sources(common
PRIVATE
@@ -194,6 +202,11 @@ create_target_directory_groups(common)
target_link_libraries(common PUBLIC Boost::context Boost::headers fmt::fmt microprofile Threads::Threads)
target_link_libraries(common PRIVATE lz4::lz4 zstd::zstd LLVM::Demangle)
+if (ANDROID)
+ # For ASharedMemory_create
+ target_link_libraries(common PRIVATE android)
+endif()
+
if (YUZU_USE_PRECOMPILED_HEADERS)
target_precompile_headers(common PRIVATE precompiled_headers.h)
endif()